Skip to main content
CVE-2024-48992VulnerabilityPublished Updated

Qualys discovered that needrestart, before version 3.8, allows local attackers to execute arbitrary code as root by

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-48992· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 3.8 : patch needrestart soon.

Data as of 30 Oct 2026, 15:51 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (canonical)CVSS 3.17.8
Affects
needrestart before 3.8
Patch
Available – fixed in 3.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

AI-suggested

Upgrade needrestart to version 3.8 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated in the provided data.

Description

A vulnerability in needrestart before version 3.8 allows local attackers to execute arbitrary code as root by manipulating the RUBYLIB environment variable, causing needrestart to run the Ruby interpreter with attacker-controlled code.

References

Community reviews

Loading reviews…