Skip to main content
CVE-2025-14905VulnerabilityPublished Updated

Red Hat Security Advisory: 389-ds:1.4 security update

Affects Red Hat 389-ds:1.4Source GCVE Database

0
Compare
Authoritative record:CVE-2025-14905· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade the Red Hat redhat/389-ds-base package to 10.2 or 9.8 soon.

Data as of 5 Nov 2026, 18:33 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.2
Patch
Available – fixed in 10.2, 9.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Red Hat redhat/389-ds-base package to 10.2 or 9.8.

Affected software

ProductAffectedFixed in
Red Hatredhat/389-ds-basepkg:rpm/redhat/389-ds-baseOther threatsAffected
  • >=9.0.0 <9.8
  • >=10.0.0 <10.2
Fixed in
  • 9.8
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated 389-ds-base packages that fix this vulnerability. Users should apply the security update as described in the Red Hat advisory RHSA-2026:5576 and the referenced article https://access.redhat.com/articles/11258. Applying these official patches fully mitigates the risk. No additional mitigation steps are required beyond applying the update.

Description

A heap buffer overflow vulnerability (CVE-2025-14905) exists in the 389 Directory Server (389-ds-base) version 1.4, which could allow remote code execution and denial of service. Red Hat has issued a security update for this vulnerability affecting Red Hat Enterprise Linux 8.8 variants. The update addresses the flaw by patching the affected 389-ds-base packages.

References

Community reviews

Loading reviews…