Skip to main content
CVE-2025-15059VulnerabilityPublished Updated

Red Hat Security Advisory: gimp security update

Affects Red Hat gimpSource GCVE Database

0
Compare

Not known to be exploited : upgrade Red Hat gimp to 2.99.8-4.el9_2.4 soon.

Data as of 5 Nov 2026, 18:32 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 2.99.8-4.el9_2.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Red Hat gimp to 2.99.8-4.el9_2.4.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • <2.99.8-4.el9_2.4
Fixed in
  • 2.99.8-4.el9_2.4

AI-suggested

Red Hat has released updated GIMP packages that fix this vulnerability. Users of Red Hat Enterprise Linux 9.2 and related variants should apply the provided security update (gimp-2.99.8-4.el9_2.4) as detailed in the Red Hat advisory (RHSA-2026:2953) to remediate this issue. No additional mitigation steps are indicated by the vendor.

Description

A heap-based buffer overflow vulnerability exists in GIMP via specially crafted PSP files. This flaw could potentially allow an attacker to cause a crash or execute arbitrary code when processing malicious PSP files. Red Hat has issued a security update for GIMP in Red Hat Enterprise Linux 9.2 to address this issue.

References

Community reviews

Loading reviews…