Skip to main content
CVE-2025-30472VulnerabilityPublished Updated

SUSE · security update for corosync

Affects SUSESource GCVE Database

0

Not known to be exploited : upgrade to 10.2.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/corosync to 10.2.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/corosyncpkg:rpm/redhat/corosyncOther threatsAffected
  • =10.0
  • <10.2.1
Fixed in
  • 10.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates that address this vulnerability for Red Hat Enterprise Linux versions 9 and 10 and their variants. Users should apply these updates promptly to remediate the issue. For detailed update instructions, refer to the Red Hat advisory at https://access.redhat.com/articles/11258. Since a patch is available and the vendor rates the severity as moderate, applying the official fix is the recommended mitigation.

Description

A stack buffer overflow vulnerability (CVE-2025-30472) exists in the corosync package used by Red Hat Enterprise Linux cluster software. The flaw is located in the 'orf_token_endian_convert' function. Red Hat has released security updates addressing this issue for Red Hat Enterprise Linux versions 9 and 10, including various variants such as AppStream, CodeReady Linux Builder, and High Availability. The vulnerability is rated as moderate severity by Red Hat Product Security. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…