Skip to main content
CVE-2026-50219VulnerabilityPublished Updated

Red Hat Security Advisory: expat security update

Affects Red Hat expatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-50219· Medium 4.9

Not known to be exploited · CVSS 4.9 Medium : upgrade Red Hat libexpat to 2.8.2 when convenient.

Data as of 31 Oct 2026, 22:36 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.8.2
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade libexpat and libexpat/libexpat to 2.8.2.

Affected software

ProductAffectedFixed in
libexpat projectlibexpatAffected
  • <2.8.2
Fixed in
  • 2.8.2
GitHublibexpat/libexpatpkg:github/libexpat/libexpatOther threatsAffected
  • <2.8.2
Fixed in
  • 2.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated expat packages that fix these vulnerabilities. Users of Red Hat Enterprise Linux 8 should apply the security update expat-2.5.0-2.el8_10.2 or later as provided in advisory RHSA-2026:64809. Detailed update instructions are available at https://access.redhat.com/articles/11258. Applying this update mitigates the vulnerabilities; no additional action is required.

Description

Two security vulnerabilities have been identified in the expat C library used for XML parsing. The first is a use-after-free vulnerability caused by improper handler call depth tracking (CVE-2026-50219). The second is a heap-based buffer overflow that can lead to arbitrary code execution (CVE-2026-56132). These issues affect Red Hat Enterprise Linux 8 across multiple architectures. Red Hat has released updated expat packages to address these vulnerabilities.

References

Community reviews

Loading reviews…