Skip to main content
CVE-2026-50219VulnerabilityPublished Updated

Red Hat Security Advisory: expat security update

Affects Red Hat expatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-50219· Medium 4.9

Not known to be exploited · CVSS 4.9 Medium : upgrade Red Hat libexpat to 2.8.2 when convenient.

Data as of 31 Oct 2026, 22:36 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.8.2
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade libexpat and libexpat/libexpat to 2.8.2.

Affected software

ProductAffectedFixed in
libexpat projectlibexpatAffected
  • <2.8.2
Fixed in
  • 2.8.2
GitHublibexpat/libexpatpkg:github/libexpat/libexpatOther threatsAffected
  • <2.8.2
Fixed in
  • 2.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated expat packages (version 2.7.3-1.el10_2.3) for Red Hat Enterprise Linux 10 and its variants that fix these vulnerabilities. Users should apply these official updates promptly following Red Hat's guidance at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the provided patches.

Description

Two security vulnerabilities have been identified in the expat C library used for XML parsing. These include a use-after-free vulnerability caused by improper handler call depth tracking (CVE-2026-50219) and a heap-based buffer overflow that can lead to arbitrary code execution (CVE-2026-56132). Red Hat has issued a security advisory for Red Hat Enterprise Linux 10, providing updated expat packages to address these issues. The vulnerabilities are rated as having moderate security impact. Users of affected Red Hat Enterprise Linux 10 variants are advised to apply the provided updates.

References

Community reviews

Loading reviews…