Skip to main content
CVE-2026-30922VulnerabilityPublished Updated

Red Hat Security Advisory: fence-agents security update

Affects Red Hat fence-agentsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade Red Hat fence-agents to 10.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Red Hat fence-agents to 10.1.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=10.0 <10.1
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream EUS (v. 10.0)
  • src
  • fence-agents-0:4.16.0-5.el10_0.9.src
Fixed in
  • 10.1

AI-suggested

Red Hat has released updated fence-agents packages for Red Hat Enterprise Linux 10.0 Extended Update Support that address these vulnerabilities. Users should apply the security update as detailed in the Red Hat advisory RHSA-2026:17083 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

The fence-agents packages provide a collection of scripts for handling remote power management for cluster devices. They allow failed or unreachable nodes to be forcibly restarted and removed from the cluster. Security Fix(es): * pyjwt: PyJWT accepts unknown `crit` header extensions (RFC 7515 ?4.1.11 MUST violation) (CVE-2026-32597) * pyasn1: pyasn1 Vulnerable to Denial of Service via Unbounded Recursion (CVE-2026-30922) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…