Skip to main content
VulnerabilityPublished

CVE-2026-32597: Important · fence-agents security update

Affects fence-agents-amt-wsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-32597· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.16.0-13.el10_1.4 soon.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.16.0-13.el10_1.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 4.16.0-13.el10_1.4.

Affected software

ProductAffectedFixed in
AlmaLinux 10fence-agents-amt-wsAffected
  • <4.16.0-13.el10_1.4
Fixed in
  • 4.16.0-13.el10_1.4
AlmaLinux 10fence-agents-apcAffected
  • <4.16.0-13.el10_1.4
Fixed in
  • 4.16.0-13.el10_1.4
AlmaLinux 10fence-agents-apc-snmpAffected
  • <4.16.0-13.el10_1.4
Fixed in
  • 4.16.0-13.el10_1.4
AlmaLinux 10fence-agents-bladecenterAffected
  • <4.16.0-13.el10_1.4
Fixed in
  • 4.16.0-13.el10_1.4
AlmaLinux 10fence-agents-brocadeAffected
  • <4.16.0-13.el10_1.4
Fixed in
  • 4.16.0-13.el10_1.4
AlmaLinux 10fence-agents-cisco-mdsAffected
  • <4.16.0-13.el10_1.4
Fixed in
  • 4.16.0-13.el10_1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The fence-agents packages provide a collection of scripts for handling remote power management for cluster devices. They allow failed or unreachable nodes to be forcibly restarted and removed from the cluster. Security Fix(es): * pyjwt: PyJWT accepts unknown `crit` header extensions (RFC 7515 ?4.1.11 MUST violation) (CVE-2026-32597) * pyasn1: pyasn1 Vulnerable to Denial of Service via Unbounded Recursion (CVE-2026-30922) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…