Skip to main content
VulnerabilityPublished Updated

CVE-2026-30922: S3ql · Denial of Service in pyasn1 via Unbounded Recursion

Affects s3qlSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.8.1 soon.

Data as of 1 Nov 2026, 01:50 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.8.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade s3ql to 3.8.1.

Affected software

ProductAffectedFixed in
Homebrews3qlpkg:brew/s3qlOther threatsAffected
  • >=3.1 <3.8.1
Fixed in
  • 3.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in pyasn1 version 3.8.1 that addresses this vulnerability by presumably adding recursion depth checks or other controls. Users should upgrade to version 3.8.1 or later to remediate this issue. No additional mitigation is noted in the vendor advisory. Until patched, avoid parsing untrusted ASN.1 data with vulnerable versions.

Description

The pyasn1 library suffers from a Denial of Service vulnerability due to unbounded recursion when decoding ASN.1 data with deeply nested indefinite length SEQUENCE or SET tags. An attacker can craft a payload that causes the decoder to recurse until the Python interpreter crashes with a RecursionError or exhausts memory, crashing the host application. This affects services parsing untrusted ASN.1 data such as LDAP, SNMP, Kerberos, or X.509 parsers. Versions from 3.1 up to but not including 3.8.1 are vulnerable. A fix is available in version 3.8.1.

References

Community reviews

Loading reviews…