CVE-2026-59885: pyasn1 · Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service
Affects s3qlSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 6.2.2_1 or 3.8.1 soon.
Data as of 1 Nov 2026, 01:50 UTC
- Patch
- Available – fixed in 6.2.2_1, 3.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade s3ql to 6.2.2_1 or 3.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrews3qlpkg:brew/s3qlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patch by upgrading pyasn1 to version 3.8.1 or later, or 6.2.2_1 or later, where the vulnerability is fixed. As a workaround, limit the size of untrusted ASN.1 input before decoding to reduce risk. No other mitigations are specified.
Description
CVE-2026-59885 is a denial of service vulnerability in the pyasn1 library affecting BER, CER, and DER decoders and encoders. The flaw causes quadratic time complexity when processing OBJECT IDENTIFIER and RELATIVE-OID values with many arcs, leading to high CPU consumption from small crafted payloads. This impacts applications decoding untrusted ASN.1 data such as certificates, LDAP, SNMP, and Kerberos. The issue is fixed in pyasn1 versions 3.8.1 and 6.2.2_1.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-8ppf-4f7h-5ppj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59885 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/45bdb19eb7df4b3780fe9c912c63e99bffc39dd9 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)