Skip to main content
VulnerabilityPublished Updated

CVE-2026-59886: pyasn1 · Uncontrolled resource consumption when converting decoded REAL values

Affects s3qlSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.2.2_1 or 3.8.1 soon.

Data as of 1 Nov 2026, 01:50 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.2.2_1, 3.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade s3ql to 6.2.2_1 or 3.8.1.

Affected software

ProductAffectedFixed in
Homebrews3qlpkg:brew/s3qlOther threatsAffected
  • >=3.1 <3.8.1
  • >=6.0.0 <6.2.2_1
Fixed in
  • 3.8.1
  • 6.2.2_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied: upgrade to pyasn1 version 0.6.4 or s3ql versions 3.8.1 or 6.2.2_1 or later. The fix prevents large intermediate integer construction during float conversion and raises OverflowError for out-of-range values. As a workaround, avoid converting, printing, or comparing decoded Real objects from untrusted sources; instead, inspect the raw (mantissa, base, exponent) tuple directly.

Description

CVE-2026-59886 is a denial of service vulnerability in the pyasn1 library's handling of ASN.1 REAL values. The issue arises when converting decoded REAL values with very large exponents to Python floats, causing excessive CPU and memory consumption that can hang processes. This affects pyasn1 versions >=3.1 <3.8.1 and >=6.0.0 <6.2.2_1. The vulnerability is fixed in versions 3.8.1 and 6.2.2_1.

References

Community reviews

Loading reviews…