Skip to main content
CVE-2026-26007VulnerabilityPublished Updated

Red Hat Security Advisory: fence-agents security update

Affects Red Hat fence-agentsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-26007· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade Red Hat fence-agents to 46.0.5 soon.

Data as of 30 Oct 2026, 00:06 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 46.0.5
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade cryptography to 46.0.5.

Affected software

ProductAffectedFixed in
pycacryptographyAffected
  • <46.0.5
Fixed in
  • 46.0.5

AI-suggested

Red Hat has released updated fence-agents packages for Red Hat Enterprise Linux 9 and related variants that fix these vulnerabilities. Users should apply the security update as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issues. No additional mitigation steps are indicated beyond applying the official patch.

Description

Red Hat has issued a security advisory for fence-agents packages used in remote power management for cluster devices. The update addresses two vulnerabilities: CVE-2026-26007, a cryptography subgroup attack due to missing subgroup validation for SECT curves, and CVE-2026-32597, where PyJWT accepts unknown 'crit' header extensions violating RFC 7515 requirements. These vulnerabilities could impact the security of cluster node management. The advisory rates the update as important and provides fixes for Red Hat Enterprise Linux 9 and related variants.

References

Community reviews

Loading reviews…