Skip to main content
CVE-2026-44660VulnerabilityPublished Updated

Red Hat Security Advisory: General availability of the satellite/iop-host-inventory-rhel9 container image

Affects Red Hat python-lsp-serverSource GCVE Database

0
Compare

Not known to be exploited : upgrade Red Hat python-lsp-server to 1.14.0_2 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14.0_2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade python-lsp-server to 1.14.0_2.

Affected software

ProductAffectedFixed in
Homebrewpython-lsp-serverpkg:brew/python-lsp-serverOther threatsAffected
  • >=1.6.0 <1.14.0_2
Fixed in
  • 1.14.0_2
Ubuntu 14.04 LTSpandaspkg:deb/ubuntu/pandas?arch=source&distro=trustyOther threatsAffected
  • =0.12.0-2ubuntu1
  • =0.13.1-2ubuntu1
  • =0.13.1-2ubuntu2
Fixed in–
Ubuntu 16.04 LTScollada2gltfpkg:deb/ubuntu/collada2gltf?arch=source&distro=xenialOther threatsAffected
  • =20140924-3
Fixed in–
Ubuntu 16.04 LTSpandaspkg:deb/ubuntu/pandas?arch=source&distro=xenialOther threatsAffected
  • 0.15.0-2 – 0.17.1-3ubuntu2
4 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSujsonpkg:deb/ubuntu/ujson?arch=source&distro=esm-apps/xenialOther threatsAffected
  • =1.33-1
  • =1.33-1build1
  • =1.33-1ubuntu0.1~esm2
Fixed in–
Ubuntu 18.04 LTScollada2gltfpkg:deb/ubuntu/collada2gltf?arch=source&distro=bionicOther threatsAffected
  • =20140924-4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in UltraJSON version 5.12.1. Users should upgrade to this version to remediate the vulnerability. Alternatively, as a workaround, replace calls to ujson.dump() with file.write(ujson.dumps(obj)) to avoid the memory leak. No other mitigation actions are specified.

Description

A memory leak vulnerability exists in UltraJSON (ujson) when using ujson.dump() to write JSON to a file-like object that raises an exception during the write operation. The leak occurs because the serialized JSON string object is not properly decremented, causing memory to grow linearly with each failed write. This affects applications that serialize data using ujson.dump() to potentially attacker-controlled file-like objects that can fail. The issue is fixed in UltraJSON version 5.12.1. A workaround is to replace ujson.dump() with file.write(ujson.dumps(obj)), which avoids the leak.

References

Community reviews

Loading reviews…