Skip to main content
CVE-2025-27832VulnerabilityPublished Updated

Red Hat Security Advisory: ghostscript security update

Affects Red Hat ghostscriptSource GCVE Database

0
Compare
Authoritative record:CVE-2025-27832· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade Red Hat ghostscript to 9.54.0-12.el9_2.3 as a priority.

Data as of 5 Nov 2026, 19:17 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.54.0-12.el9_2.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Red Hat ghostscript to 9.54.0-12.el9_2.3.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=9.2 <9.54.0-12.el9_2.3
Fixed in
  • 9.54.0-12.el9_2.3

AI-suggested

Red Hat has released an official security update for Ghostscript in Red Hat Enterprise Linux 9.2 that addresses this buffer overflow vulnerability. Users should apply the update as described in Red Hat advisory RHSA-2025:22869 and the referenced article https://access.redhat.com/articles/11258 to remediate the issue. No additional mitigation steps are indicated by the vendor.

Description

A buffer overflow vulnerability exists in the NPDL device component of Ghostscript, a suite used for rendering PostScript and PDF documents. This flaw could potentially lead to memory corruption when processing compressed data. Red Hat has issued a security update addressing this issue in Ghostscript for Red Hat Enterprise Linux 9.2. The vulnerability is rated as moderate in severity by Red Hat Product Security.

References

Community reviews

Loading reviews…