Skip to main content
CVE-2025-53020VulnerabilityPublished Updated

Red Hat Security Advisory: httpd:2.4 security update

Affects Red Hat httpd:2.4Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-53020· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat httpd to 2.4.64 soon.

Data as of 30 Oct 2026, 03:14 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.64.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.64
Fixed in
  • 2.4.64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the httpd 2.4 packages addressing all listed vulnerabilities. Users should apply the update as described in Red Hat advisory RHSA-2026:36373 and the referenced article https://access.redhat.com/articles/11258 to remediate these issues. No additional mitigation steps are indicated beyond applying the official patch.

Description

Multiple security vulnerabilities have been identified and fixed in the Apache HTTP Server (httpd) 2.4 packages provided by Red Hat. These include denial of service (DoS) attacks via HTTP/2 memory increase and compression bomb, heap-based buffer over-reads and buffer overflow in mod_proxy_ajp, a NULL pointer dereference causing child process crashes in mod_authn_socache, and an arbitrary code execution vulnerability through mod_proxy_ajp. Red Hat has released an important security update addressing these issues for Red Hat Enterprise Linux 8.8 variants.

References

Community reviews

Loading reviews…