CVE-2025-38350: Linux azure · In the Linux kernel, the following vulnerability has been resolved: net/sched: Always pass notifications when child class becomes empty Certain
Affects linux-azureSource GCVE Database
Not known to be exploited · CVSS 7.8 High · patch available : patch linux-azure soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/kernel-rtpkg:rpm/redhat/kernel-rtOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Red Hat users should update to the kernel-rt packages version 4.18.0-553.75.1.rt7.416.el8_10 or later and reboot the system. Ubuntu users should upgrade to the specified fixed kernel versions (e.g., 6.14.0-29.29 or later) and reboot. For GKE users, upgrade Ubuntu node pools to the fixed versions listed (e.g., 1.28.15-gke.2697000 or later). GKE Autopilot clusters are not impacted by default but should avoid using seccomp Unconfined profile or allowing CAP_NET_ADMIN to reduce risk. No additional mitigations are required beyond applying the official patches and rebooting.
Description
CVE-2025-38350 is a high-severity vulnerability in the Linux kernel's network traffic control subsystem that can lead to privilege escalation on Container-Optimized OS nodes. It affects certain versions of Red Hat Enterprise Linux 8 Real Time kernels and Ubuntu Linux kernels, including those used in Google Kubernetes Engine (GKE) Standard clusters. GKE Autopilot clusters are not impacted by default but may be vulnerable if configured with certain profiles. The vulnerability has been addressed by patches released by Red Hat and Ubuntu, requiring system updates and reboots. Users should upgrade to the specified fixed kernel versions to mitigate the issue.
References
- access.redhat.com/errata/RHSA-2025:15786 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2382054 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2383407 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2383519 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_15786.json (opens in a new tab)
- ubuntu.com/security/CVE-2025-38350 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-38350 (opens in a new tab)
- git.kernel.org/linus/103406b38c600fec1fe375a77b27d87e314aea09 (opens in a new tab)
- git.kernel.org/stable/c/103406b38c600fec1fe375a77b27d87e314aea09 (opens in a new tab)
- git.kernel.org/stable/c/3b290923ad2b23596208c1e29520badef4356a43 (opens in a new tab)
- git.kernel.org/stable/c/7874c9c132e906a52a187d045995b115973c93fb (opens in a new tab)
- git.kernel.org/stable/c/a44acdd9e84a211989ff4b9b92bf3545d8456ad5 (opens in a new tab)
- git.kernel.org/stable/c/a553afd91f55ff39b1e8a1c4989a29394c9e0472 (opens in a new tab)
- git.kernel.org/stable/c/e269f29e9395527bc00c213c6b15da04ebb35070 (opens in a new tab)
- git.kernel.org/stable/c/e9921b57dca05ac5f4fa1fa8e993d4f0ee52e2b7 (opens in a new tab)
- git.kernel.org/stable/c/f680a4643c6f71e758d8fe0431a958e9a6a4f59d (opens in a new tab)
- ubuntu.com/security/notices/USN-7722-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7724-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7725-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7725-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7726-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7726-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7726-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7726-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7725-3 (opens in a new tab)