Skip to main content
CVE-2026-71226VulnerabilityPublished

Red Hat Security Advisory: libkcapi security update

Affects Red Hat libkcapiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-71226· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade Red Hat libkcapi to 1.5.1 soon.

Data as of 2 Nov 2026, 06:43 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.3
Patch
Available – fixed in 1.5.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade libkcapi to 1.5.1.

Affected software

ProductAffectedFixed in
Stephan MuellelibkcapiAffected
  • >=0.12.0 <1.5.1
Fixed in
  • 1.5.1
GitHublibkcapipkg:github/libkcapiOther threatsAffected
  • >=0.12.0 <1.5.1
Fixed in
  • 1.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for libkcapi in Red Hat Enterprise Linux 8.8 variants that addresses this memory corruption issue. Users should apply the update as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official patch.

Description

A memory corruption vulnerability exists in libkcapi due to uncanceled asynchronous I/O (AIO) requests on error in its one-shot AIO path. libkcapi is a user-space library that interfaces with the Linux kernel crypto API via netlink, allowing unprivileged processes to access kernel cryptographic services. This vulnerability is identified as CVE-2026-71226 and has been rated as having moderate security impact by Red Hat. An update addressing this issue is available for Red Hat Enterprise Linux 8.8 variants.

References

Community reviews

Loading reviews…