Skip to main content
CVE-2026-6477VulnerabilityPublished Updated

Red Hat Security Advisory: libpq security update

Affects Red Hat libpqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-6477· High 8.8

Not known to be exploited · CVSS 8.8 High · fixed in Red Hat package updates : patch the Red Hat redhat/libpq package soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.1, 18.4.0, 17.10.0 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Red Hatredhat/libpqpkg:rpm/redhat/libpqOther threatsAffected
  • >=8.6 <8.6.1
Fixed in
  • 8.6.1
Bitnamipostgresqlpkg:bitnami/postgresqlOther threatsAffected
  • <14.23.0
  • >=15.0.0 <15.18.0
  • >=16.0.0 <16.14.0
  • >=17.0.0 <17.10.0
  • >=18.0.0 <18.4.0
Fixed in
  • 14.23.0
  • 15.18.0
  • 16.14.0
  • 17.10.0
  • 18.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released by Red Hat in updated libpq packages for affected Red Hat Enterprise Linux versions (notably RHEL 8.6). Users should apply these updates promptly. Additionally, clients should avoid connecting to untrusted or potentially compromised PostgreSQL servers to mitigate risk. The vendor advisory explicitly recommends only connecting to trusted servers and updating to patched versions. No other mitigations are specified.

Description

The libpq package provides the PostgreSQL client library, which allows client programs to connect to PostgreSQL servers. Security Fix(es): * postgresql: PostgreSQL libpq: Buffer overflow allows server superuser to overwrite client stack memory (CVE-2026-6477) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…