Skip to main content
CVE-2026-44236VulnerabilityPublished Updated

Red Hat Security Advisory: librabbitmq security update

Affects Red Hat librabbitmqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-44236· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade Red Hat rabbitmq-c to 0.16.0 soon.

Data as of 29 Oct 2026, 07:44 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.16.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade rabbitmq-c and alanxz/rabbitmq-c to 0.16.0.

Affected software

ProductAffectedFixed in
alanxzrabbitmq-cAffected
  • <0.16.0
Fixed in
  • 0.16.0
GitHubalanxz/rabbitmq-cpkg:github/alanxz/rabbitmq-cOther threatsAffected
  • <0.16.0
Fixed in
  • 0.16.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated librabbitmq packages that fix this vulnerability. Users of Red Hat Enterprise Linux 9 and its Extended Update Support variants should apply the provided security updates as described in Red Hat advisory RHSA-2026:82094. No additional mitigation steps are indicated by the vendor.

Description

A heap buffer overflow vulnerability (CVE-2026-44236) was discovered in the librabbitmq AMQP client library used in Red Hat Enterprise Linux 9. This flaw can lead to a denial of service condition. Red Hat has issued an important security update addressing this issue in librabbitmq packages for multiple architectures and variants of RHEL 9.

References

Community reviews

Loading reviews…