Skip to main content
CVE-2026-44236VulnerabilityPublished Updated

Red Hat Security Advisory: librabbitmq security update

Affects Red Hat librabbitmqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-44236· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade Red Hat rabbitmq-c to 0.16.0 soon.

Data as of 29 Oct 2026, 07:44 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.16.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade rabbitmq-c and alanxz/rabbitmq-c to 0.16.0.

Affected software

ProductAffectedFixed in
alanxzrabbitmq-cAffected
  • <0.16.0
Fixed in
  • 0.16.0
GitHubalanxz/rabbitmq-cpkg:github/alanxz/rabbitmq-cOther threatsAffected
  • <0.16.0
Fixed in
  • 0.16.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated librabbitmq packages for Red Hat Enterprise Linux 10 and related products that fix this vulnerability. Users should apply these official updates as described in Red Hat advisory RHSA-2026:84795 and the referenced article https://access.redhat.com/articles/11258 to remediate the issue.

Description

A heap buffer overflow vulnerability (CVE-2026-44236) has been identified in the librabbitmq client library used for AMQP communication. This flaw can lead to denial of service conditions. Red Hat has issued an important security advisory with updates available for Red Hat Enterprise Linux 10 and related products to address this issue.

References

Community reviews

Loading reviews…