Skip to main content
CVE-2026-48864VulnerabilityPublished Updated

Red Hat Security Advisory: libsolv security update

Affects Red Hat libsolvSource GCVE Database

0
Compare
Authoritative record:CVE-2026-48864· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade the Red Hat redhat/libsolv package to 8.8.1 soon.

Data as of 6 Nov 2026, 11:36 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.8
Patch
Available – fixed in 8.8.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Red Hat redhat/libsolv package to 8.8.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsolvpkg:rpm/redhat/libsolvOther threatsAffected
  • >=8.8 <8.8.1
Fixed in
  • 8.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsolv packages that fix this vulnerability. Users of affected Red Hat Enterprise Linux 8.8 variants and update services should apply the security update as described in Red Hat advisory RHSA-2026:48816 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

A heap buffer overflow vulnerability exists in the libsolv library used for resolving package dependencies, triggered by unchecked decompression of malicious .solv page data. This flaw is identified as CVE-2026-48864 and has been rated with moderate security impact by Red Hat. The vulnerability affects Red Hat Enterprise Linux 8.8 variants and related update services. Red Hat has issued security updates to address this issue.

References

Community reviews

Loading reviews…