Skip to main content
CVE-2024-52530VulnerabilityPublished Updated

Red Hat Security Advisory: libsoup security update

Affects Red Hat libsoupSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-52530· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the Debian debian/libsoup package to 3.6.0 soon.

Data as of 5 Nov 2026, 17:00 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 3.6.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/libsoup package to 3.6.0.

Affected software

ProductAffectedFixed in
Debiandebian/libsouppkg:deb/debian/libsoupOther threatsAffected
  • <3.6.0
Fixed in
  • 3.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates for libsoup in Red Hat Enterprise Linux 9 to address these vulnerabilities. Users should apply the available updates as described in the Red Hat advisory (RHSA-2024:9559) and the referenced article (https://access.redhat.com/articles/11258). No additional mitigations are specified by the vendor beyond applying the official patches.

Description

Two security vulnerabilities have been identified in the libsoup HTTP client and server library for GNOME, used in Red Hat Enterprise Linux 9. The first is an infinite loop vulnerability when reading websocket data (CVE-2024-52532). The second is an HTTP request smuggling vulnerability caused by improper handling of null bytes at the ends of header names (CVE-2024-52530). Red Hat has issued an important security advisory with updates to address these issues.

References

Community reviews

Loading reviews…