Skip to main content
CVE-2024-34459VulnerabilityPublished Updated

Red Hat Security Advisory: libxml2 security update

Affects Red Hat libxml2Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34459· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat libxml2 to 2.12.7 or 2.11.8 soon.

Data as of 5 Nov 2026, 13:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.12.7, 2.11.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade gnome/libxml2 to 2.12.7 or 2.11.8.

Affected software

ProductAffectedFixed in
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threatsAffected
  • <2.11.8
  • <2.12.7
Fixed in
  • 2.11.8
  • 2.12.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libxml2 packages for Red Hat Enterprise Linux 9.2 and related variants that fix this vulnerability. Users should apply these official updates as described in the Red Hat advisory (RHSA-2026:33633) to remediate the issue. No additional mitigation steps are indicated by the vendor.

Description

A buffer over-read vulnerability (CVE-2024-34459) was identified in the libxml2 library, specifically in the xmlHTMLPrintFileContext function within xmllint.c. This issue has been rated as having a low security impact by Red Hat. An update addressing this vulnerability is available for Red Hat Enterprise Linux 9.2 and related variants.

References

Community reviews

Loading reviews…