Red Hat Security Advisory: libxml2 security update
Affects Red Hat libxml2Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade Red Hat libxml2 to 2.12.7 or 2.11.8 soon.
Data as of 5 Nov 2026, 13:20 UTC
- Patch
- Available – fixed in 2.12.7, 2.11.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade gnome/libxml2 to 2.12.7 or 2.11.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update for libxml2 is available from Red Hat as part of Red Hat Enterprise Linux 9.6 Extended Update Support. Users should apply the updated packages (libxml2-2.9.13-12.el9_6.2 or later) as provided in the Red Hat advisory RHSA-2026:33634. No additional mitigation steps are indicated by the vendor.
Description
A buffer over-read vulnerability exists in the libxml2 library's xmlHTMLPrintFileContext function, identified as CVE-2024-34459. This issue affects Red Hat Enterprise Linux 9.6 Extended Update Support and related variants. The vulnerability has been rated with a low security impact by Red Hat Product Security. A security update addressing this flaw is available and should be applied to affected systems.