Skip to main content
CVE-2024-34459VulnerabilityPublished Updated

Red Hat Security Advisory: libxml2 security update

Affects Red Hat libxml2Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34459· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat libxml2 to 2.12.7 or 2.11.8 soon.

Data as of 5 Nov 2026, 13:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.12.7, 2.11.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade gnome/libxml2 to 2.12.7 or 2.11.8.

Affected software

ProductAffectedFixed in
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threatsAffected
  • <2.11.8
  • <2.12.7
Fixed in
  • 2.11.8
  • 2.12.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libxml2 packages for Red Hat Enterprise Linux 8.8 variants that address this buffer over-read vulnerability. Users should apply these official updates as detailed in Red Hat advisory RHSA-2026:27739 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the update.

Description

A buffer over-read vulnerability (CVE-2024-34459) exists in the libxml2 library's xmlHTMLPrintFileContext function within xmllint.c. This issue has been rated as having a low security impact by Red Hat. The vulnerability affects Red Hat Enterprise Linux 8.8 variants and has been addressed in updated libxml2 packages. Users are advised to apply the provided security update to mitigate the issue.

References

Community reviews

Loading reviews…