SUSE · security update for libxslt
Affects SUSESource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 9.2-10 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.2-10, 8.0.461, 1.8.0
Exploitation evidence
Disclosed: evidence found.
CVE published 14 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade redhat/libxslt to 9.2-10; jre to 8.0.461 or 1.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/libxsltpkg:rpm/redhat/libxsltOther threats | Affected
| Fixed in
|
Bitnamijrepkg:bitnami/jreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available from Red Hat and other vendors to remediate this vulnerability. Users should apply the official security updates as provided in the Red Hat advisory RHSA-2025:3107. Refer to the vendor's update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps.
Description
A use-after-free vulnerability (CVE-2025-24855) exists in libxslt before version 1.1.43, specifically in numbers.c during nested XPath evaluations. This vulnerability affects functions such as xsltNumberFormatGetValue and xsltEvalXPathPredicate. It is rated as high severity. A patch is available from Red Hat and other vendors to address this issue.
References
- access.redhat.com/errata/RHSA-2025:3107 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2352483 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_3107.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:3389 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_3389.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:3528 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_3528.json (opens in a new tab)
- gitlab.gnome.org/GNOME/libxslt/-/issues/128 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00015.html (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-24855 (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_3107.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-March/000995.html (opens in a new tab)
- suse.com/security/cve/CVE-2025-24855/ (opens in a new tab)