Skip to main content
CVE-2026-32710VulnerabilityPublished Updated

SUSE mariadb · Security update for mariadb

Affects SUSE mariadbSource GCVE Database

0
Compare
Authoritative record:CVE-2026-32710· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade the Red Hat redhat/mariadb package to 11.8.6 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.8.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Red Hat redhat/mariadb package to 11.8.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/mariadbpkg:rpm/redhat/mariadbOther threatsAffected
  • <11.8.6 >=11.8.0
Fixed in
  • 11.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update to MariaDB version 11.8.6 is available and should be applied to affected systems. Red Hat has released updated packages for Red Hat Enterprise Linux 10 distributions to address this vulnerability. Users should follow vendor guidance to apply these updates promptly. No additional mitigations are indicated by the vendor advisory.

Description

A heap-based buffer overflow vulnerability exists in MariaDB's JSON_SCHEMA_VALID() function, identified as CVE-2026-32710. This flaw can lead to a crash or remote code execution. The issue affects MariaDB versions from 11.8.0 up to but not including 11.8.6. A security update to version 11.8.6 has been released to address this vulnerability. Red Hat has rated the impact as Moderate for their Enterprise Linux 10 distributions and has provided updated packages to remediate the issue.

References

Community reviews

Loading reviews…