Skip to main content
CVE-2026-43951VulnerabilityPublished Updated

Red Hat Security Advisory: mod_http2 security, bug fix, and enhancement update

Affects Red Hat mod_http2 security,Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-43951· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade Red Hat httpd to 2.4.68 when convenient.

Data as of 6 Nov 2026, 02:20 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache/httpd to 2.4.68.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.0 <=2.4.67
Fixed in–
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • >=2.4.0 <2.4.68
Fixed in
  • 2.4.68

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated mod_http2 packages for Red Hat Enterprise Linux 9 that fix these vulnerabilities. Users should apply the updates as described in the Red Hat advisory RHSA-2026:59387 and the referenced article https://access.redhat.com/articles/11258 to remediate these issues. No additional mitigation steps are indicated beyond applying the official patches.

Description

Two security vulnerabilities affecting the Apache HTTP Server mod_http2 module and related components have been addressed in Red Hat Enterprise Linux 9. These include a Use After Free vulnerability (CVE-2026-48913) in mod_http2 that could allow arbitrary code execution or denial of service, and an Out-of-bounds Read vulnerability (CVE-2026-43951) in mod_headers and mod_mime. Red Hat has released updates to fix these issues in the mod_http2 package for RHEL 9.

References

Community reviews

Loading reviews…