Skip to main content
CVE-2026-25506VulnerabilityPublished Updated

Red Hat Security Advisory: munge security update

Affects Red Hat mungeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-25506· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade Red Hat munge to 0.5.18 soon.

Data as of 5 Nov 2026, 23:05 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.5.18
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade munge to 0.5.18.

Affected software

ProductAffectedFixed in
dunmungeAffected
  • >=0.5 <0.5.18
Fixed in
  • 0.5.18

AI-suggested

Red Hat has released an updated package for MUNGE (version 0.5.13-2.el8_4.1) that fixes this buffer overflow vulnerability. Users of affected Red Hat Enterprise Linux 8.4 systems should apply this security update promptly. For detailed update instructions, refer to Red Hat's advisory at https://access.redhat.com/articles/11258. No other mitigation steps are indicated.

Description

A buffer overflow vulnerability in MUNGE's message unpacking allows key leakage and credential forgery. MUNGE is an authentication service used in HPC clusters to authenticate UIDs and GIDs across hosts sharing a cryptographic key. This flaw could enable attackers to forge credentials within the security realm.

References

Community reviews

Loading reviews…