Skip to main content
CVE-2026-9256VulnerabilityPublished

Red Hat Security Advisory: nginx security update

Affects Red Hat nginxSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-9256· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in Red Hat package updates : patch Red Hat nginx soon.

Data as of 2 Nov 2026, 06:30 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 37.0.1.1, 1.31.1, 1.30.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade NGINX to 37.0.1.1 (Plus); 1.31.1 or 1.30.2 (Open Source).

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.0 <37.0.1.1
  • =R36
  • =R32
Fixed in
  • 37.0.1.1
F5NGINX Open SourceAffected
  • >=1.31.0 <1.31.1
  • >=1.30.0 <1.30.2
  • >=0.1.17 <=0.9.7
Fixed in
  • 1.31.1
  • 1.30.2

AI-suggested

Red Hat has released updated nginx packages for Red Hat Enterprise Linux 9.4 and related variants that address these vulnerabilities. Users should apply these official updates promptly following Red Hat's guidance at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the provided security updates.

Description

Multiple security vulnerabilities have been identified in nginx, a widely used web and proxy server. These include code execution, denial of service, heap-based buffer overflow, heap buffer over-read, and memory disclosure issues affecting various nginx modules such as ngx_http_rewrite_module, HTTP/2 header processing, and ngx_http_slice_module. Red Hat has issued an important security advisory with updates for Red Hat Enterprise Linux 9.4 to address these vulnerabilities.

References

Community reviews

Loading reviews…