Skip to main content
CVE-2026-56434VulnerabilityPublished Updated

Red Hat Security Advisory: nginx:1.26 security update

Affects Red Hat nginx:1.26Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-56434· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in Red Hat package updates : update Red Hat nginx:1.26 when convenient.

Data as of 2 Nov 2026, 06:29 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 37.0.3.1, 1.31.3, 1.30.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade NGINX to 37.0.3.1 (Plus); 1.31.3 or 1.30.4 (Open Source).

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.0.0.1 <37.0.3.1
  • >=R33
  • =R36
Fixed in
  • 37.0.3.1
F5NGINX Open SourceAffected
  • >=1.31.2 <1.31.3
Fixed in
  • 1.31.3
F5NGINX Open SourceAffected
  • >=0.8.11 <1.30.4
Fixed in
  • 1.30.4

AI-suggested

Red Hat has released updated nginx packages for Red Hat Enterprise Linux 9 that fix these vulnerabilities. Users should apply the security update as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issues. No additional mitigation steps are indicated beyond applying the official update.

Description

Two security vulnerabilities have been identified in nginx version 1.26 used in Red Hat Enterprise Linux 9. These include a heap buffer over-read that can lead to memory modification or denial of service (CVE-2026-56434), and a memory disclosure and denial of service issue in the ngx_http_slice_module (CVE-2026-60005). Red Hat has released security updates addressing these issues.

References

Community reviews

Loading reviews…