Skip to main content
CVE-2026-9256VulnerabilityPublished Updated

Red Hat Security Advisory: nginx security update

Affects Red Hat nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2026-9256· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in Red Hat package updates : patch Red Hat nginx soon.

Data as of 2 Nov 2026, 06:29 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 37.0.1.1, 1.31.1, 1.30.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade NGINX to 37.0.1.1 (Plus); 1.31.1 or 1.30.2 (Open Source).

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.0 <37.0.1.1
  • =R36
  • =R32
Fixed in
  • 37.0.1.1
F5NGINX Open SourceAffected
  • >=1.31.0 <1.31.1
  • >=1.30.0 <1.30.2
  • >=0.1.17 <=0.9.7
Fixed in
  • 1.31.1
  • 1.30.2

AI-suggested

Red Hat has released updated nginx packages for Red Hat Enterprise Linux 10 and related products that fix CVE-2026-9256. Users should apply these official updates as described in the Red Hat advisory (RHSA-2026:29874) and the referenced article (https://access.redhat.com/articles/11258) to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the vendor-provided patches.

Description

A security vulnerability (CVE-2026-9256) affecting the ngx_http_rewrite_module of nginx in Red Hat Enterprise Linux 10 allows for potential code execution and denial of service. Red Hat has issued an important security advisory with an update to address this issue. The vulnerability impacts multiple architectures and product variants of Red Hat Enterprise Linux 10 and related CodeReady Linux Builder packages. The advisory references a fix available in updated nginx packages.

References

Community reviews

Loading reviews…