Skip to main content
CVE-2026-42055VulnerabilityPublished Updated

Red Hat Security Advisory: nginx:1.24 security, bug fix, and enhancement update

Affects Red Hat nginx:1.24 security,Source GCVE Database

0
Compare
Authoritative record:CVE-2026-42055· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in Red Hat package updates : patch Red Hat nginx:1.24 security, soon.

Data as of 30 Oct 2026, 20:36 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.5% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.31.2, 1.30.3, R36 P6 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX to 1.31.2 or 1.30.3 (Open Source); R36 P6 or 37.0.2.1 (Plus).

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.13.10 <1.31.2
Fixed in
  • 1.31.2
F5NGINX Open SourceAffected
  • >=1.30.2 <1.30.3
Fixed in
  • 1.30.3
F5NGINX PlusAffected
  • >=37.0 <37.0.2.1
  • =R36
Fixed in
  • R36 P6
  • 37.0.2.1

AI-suggested

Red Hat has released an official update for nginx:1.24 on Red Hat Enterprise Linux 9 that fixes this vulnerability. Users should apply the update as detailed in the Red Hat advisory RHSA-2026:36618 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

A heap-based buffer overflow vulnerability exists in nginx 1.24 when processing crafted HTTP/2 headers, potentially allowing arbitrary code execution or denial of service. This issue is tracked as CVE-2026-42055. Red Hat has released an important security update for nginx:1.24 on Red Hat Enterprise Linux 9 to address this vulnerability along with bug fixes and enhancements. The update fixes the heap overflow and resolves an ABI break caused by a previous HTTP/2 fix. No public exploit code or in-the-wild exploitation is currently known.

References

Community reviews

Loading reviews…