Skip to main content
CVE-2026-27651VulnerabilityPublished Updated

Red Hat Security Advisory: nginx:1.24 security update

Affects Red Hat nginx:1.24Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-27651· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in Red Hat package updates : patch the Red Hat redhat/nginx package soon.

Data as of 4 Nov 2026, 10:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.29.7, 1.28.3, R36 P3 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade NGINX Open Source to 1.29.7 or 1.28.3; NGINX Plus to R36 P3, R35 P2 or R32 P5; the Red Hat redhat/nginx package to 1.29.0.

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.29.0 <1.29.7
Fixed in
  • 1.29.7
F5NGINX Open SourceAffected
  • >=0.5.15 <1.28.3
Fixed in
  • 1.28.3
F5NGINX PlusAffected
  • >=R34
  • >=R33
  • =R36
  • =R35
  • =R32
Fixed in
  • R36 P3
  • R35 P2
  • R32 P5
Red Hatredhat/nginxpkg:rpm/redhat/nginxOther threatsAffected
  • <1.29.0
Fixed in
  • 1.29.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated nginx packages for Red Hat Enterprise Linux 9.6 Extended Update Support that address these vulnerabilities. Users should apply the official security update as detailed in the Red Hat advisory (RHSA-2026:15945) to remediate these issues. No additional mitigation steps are indicated beyond applying the update.

Description

Multiple security vulnerabilities have been identified in nginx version 1.24 as used in Red Hat Enterprise Linux 9.6 Extended Update Support. These include denial of service and potential code execution via specially crafted MP4 files, buffer overflow in the ngx_http_dav_module leading to denial of service or file modification, memory corruption via crafted MP4 files causing denial of service, and denial of service via undisclosed requests when the ngx_mail_auth_http_module is enabled. Red Hat has issued an important security advisory with updates to address these issues.

References

Community reviews

Loading reviews…