Skip to main content
CVE-2026-9256VulnerabilityPublished Updated

Red Hat Security Advisory: nginx:1.26 security update

Affects Red Hat nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2026-9256· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade the Red Hat redhat/nginx package to 1.26.3-9 soon.

Data as of 2 Nov 2026, 04:32 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.26.3-9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade the Red Hat redhat/nginx package to 1.26.3-9.

Affected software

ProductAffectedFixed in
Red Hatredhat/nginxpkg:rpm/redhat/nginxOther threatsAffected
  • <1.26.3-9
Fixed in
  • 1.26.3-9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated nginx packages (version 1.26.3-9) for Red Hat Enterprise Linux 9. Users should apply these official updates promptly to remediate the vulnerability. Detailed update instructions are available in the Red Hat advisory and knowledge base article linked in the vendor advisory. No additional mitigations are specified or required beyond applying the update.

Description

A security update for nginx 1.26 addresses a vulnerability in the ngx_http_rewrite_module that could allow code execution and denial of service. This issue is tracked as CVE-2026-9256 and affects Red Hat Enterprise Linux 9 distributions. The vulnerability has been rated as important by Red Hat Product Security. A fixed package version 1.26.3-9 for Red Hat Enterprise Linux 9.8 is available to remediate this issue.

References

Community reviews

Loading reviews…