Skip to main content
CVE-2026-35469VulnerabilityPublished Updated

Red Hat Security Advisory: OpenShift Container Platform 4.17.56 security and extras update

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-35469· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade Red Hat spdystream to 0.5.1 soon.

Data as of 3 Nov 2026, 11:16 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.5.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade spdystream and github.com/moby/spdystream to 0.5.1.

Affected software

ProductAffectedFixed in
mobyspdystreamAffected
  • <0.5.1
Fixed in
  • 0.5.1
Gogithub.com/moby/spdystreampkg:golang/github.com/moby/spdystreamOther threatsAffected
  • <0.5.1
Fixed in
  • 0.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages and container images in OpenShift Container Platform 4.17.56 that fix this vulnerability. Upgrades can be performed using the OpenShift CLI (oc) or the web console. Follow Red Hat's official upgrade documentation to fully apply the asynchronous errata update and ensure the fix is applied.

Description

Red Hat OpenShift Container Platform 4.17.56 includes a security update addressing a denial of service vulnerability in the kube-apiserver, kubelet, and CRI-O components via SPDY streaming code (CVE-2026-35469). This update is rated as important by Red Hat Product Security. Users of OpenShift Container Platform 4.17 are advised to upgrade to the updated packages and images to mitigate this issue.

References

Community reviews

Loading reviews…