Skip to main content
CVE-2025-6020VulnerabilityPublished Updated

Red Hat Security Advisory: pam security update

Affects Red Hat pamSource GCVE Database

0
Compare
Authoritative record:CVE-2025-6020· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade Red Hat linux-pam to 1.7.1 soon.

Data as of 5 Nov 2026, 20:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.8
Patch
Available – fixed in 1.7.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade linux-pam to 1.7.1.

Affected software

ProductAffectedFixed in
linux-pamAffected
  • <1.7.1
Fixed in
  • 1.7.1
GitHublinux-pampkg:github/linux-pamOther threatsAffected
  • <1.7.1
Fixed in
  • 1.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for Red Hat Enterprise Linux 9 and its variants to address this vulnerability. Users should apply the provided security updates as detailed in the Red Hat advisory RHSA-2025:9526 and the referenced article https://access.redhat.com/articles/11258. Applying these updates will remediate the vulnerability. No additional mitigation steps are indicated by the vendor.

Description

A directory traversal vulnerability (CVE-2025-6020) has been identified in the Linux Pluggable Authentication Modules (PAM) component used by Red Hat Enterprise Linux 9. This vulnerability could allow unauthorized access to files or directories outside the intended scope. Red Hat has issued a security advisory with an update to address this issue. The update is rated as Important by Red Hat Product Security. Multiple Red Hat Enterprise Linux 9 variants and architectures are affected. No CVSS score is provided, but the severity is described as high. No known exploits in the wild have been reported at this time.

References

Community reviews

Loading reviews…