Skip to main content
CVE-2024-3019VulnerabilityPublished Updated

Red Hat Security Advisory: pcp security update

Affects Red Hat pcpSource GCVE Database

0
Compare
Authoritative record:CVE-2024-3019· High 8.8

Not known to be exploited · CVSS 8.8 High.

Data as of 5 Nov 2026, 14:04 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.8
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Mar 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
pcpAffected
  • >=4.3.4
Fixed in–
Red Hatredhat/pcppkg:rpm/redhat/pcpOther threatsAffected
  • =4.3.4
Fixed in–
GitHubpcppkg:github/pcpOther threatsAffected
  • >=4.3.4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for Red Hat Enterprise Linux 8.4 variants that fix this vulnerability. Users should apply the security update RHSA-2024:3323 as soon as possible. For detailed update instructions, refer to Red Hat's official article at https://access.redhat.com/articles/11258. No alternative mitigations or workarounds are indicated in the advisory.

Description

A security vulnerability (CVE-2024-3019) in Performance Co-Pilot (PCP) allows remote command execution due to exposure of the Redis server backend via the pmproxy component. This affects certain Red Hat Enterprise Linux 8.4 variants. Red Hat has issued an important security update to address this issue.

References

Community reviews

Loading reviews…