Skip to main content
CVE-2024-25126VulnerabilityPublished Updated

Red Hat Security Advisory: pcs security update

Affects Red Hat pcsSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · 35% EPSS : upgrade the Red Hat redhat/pcs package to 8.6.5 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
35.3% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/pcs package to 8.6.5.

Affected software

ProductAffectedFixed in
Red Hatredhat/pcspkg:rpm/redhat/pcsOther threatsAffected
  • =8.6
  • <8.6.5
Fixed in
  • 8.6.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated pcs packages (version 0.10.12-6.el8_6.5) that address these vulnerabilities. Users should apply this security update after ensuring all previously released relevant errata have been applied. Detailed update instructions are available from Red Hat's official documentation. No additional mitigations are specified or required beyond applying the official update.

Description

The pcs packages provide a command-line configuration system for the Pacemaker and Corosync utilities. Security Fix(es): * rubygem-rack: Denial of Service Vulnerability in Rack Content-Type Parsing (CVE-2024-25126) * rubygem-rack: Possible DoS Vulnerability with Range Header in Rack (CVE-2024-26141) * rubygem-rack: Possible Denial of Service Vulnerability in Rack Header Parsing (CVE-2024-26146) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…