Skip to main content
CVE-2026-17543VulnerabilityPublished Updated

Red Hat Security Advisory: php8.4 security, bug fix, and enhancement update

Affects Red Hat php8.4 security,Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-17543· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in Debian package updates : patch the Debian debian/php package soon.

Data as of 5 Nov 2026, 23:47 UTC

CVSS 4.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.9, 8.4.24, 8.3.33 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:Y/R:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade PHP and the Debian debian/php package to 8.5.9, 8.4.24, 8.3.33 or 8.2.33.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.9
Fixed in
  • 8.5.9
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.24
Fixed in
  • 8.4.24
PHP GroupPHPAffected
  • ≥ 8.3.*, < 8.3.33
Fixed in
  • 8.3.33
PHP GroupPHPAffected
  • ≥ 8.2.*, < 8.2.33
Fixed in
  • 8.2.33
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.2.33
  • <8.3.33
  • <8.4.24
  • <8.5.9
Fixed in
  • 8.2.33
  • 8.3.33
  • 8.4.24
  • 8.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official update rebasing PHP to version 8.4.24 that addresses these vulnerabilities. Users of Red Hat Enterprise Linux 10 and its variants should apply the php8.4 update promptly following Red Hat's published guidance at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

Red Hat issued a security advisory for php8.4 addressing two important vulnerabilities: a SQL injection via improper backslash escaping (CVE-2026-17543) and an arbitrary code execution via an out-of-bounds write in the bccomp() function (CVE-2026-17544). These vulnerabilities affect PHP 8.4 and were fixed by rebasing PHP to version 8.4.24 in Red Hat Enterprise Linux 10. The update is rated as important by Red Hat Product Security. No public exploit code or in-the-wild exploitation is currently known.

References

Community reviews

Loading reviews…