Skip to main content
CVE-2026-6104VulnerabilityPublished Updated

Red Hat Security Advisory: php8.4 security update

Affects Red Hat phpSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-6104· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade Red Hat php to 8.5.6 or 8.4.21 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.6, 8.4.21
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:L/SI:N/SA:L/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade php to 8.5.6 or 8.4.21.

Affected software

ProductAffectedFixed in
Bitnamiphppkg:bitnami/phpOther threatsAffected
  • >=8.4.0 <8.4.21
  • >=8.5.0 <8.5.6
Fixed in
  • 8.4.21
  • 8.5.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is fairly simple. The most common use of PHP coding is probably as a replacement for CGI scripts. Security Fix(es): * PHP: PHP: Denial of Service via improper handling of signed characters in ctype functions (CVE-2026-7258) * PHP: PHP-FPM: PHP-FPM: Cross-Site Scripting vulnerability via improper URL sanitation (CVE-2026-6735) * php: NULL pointer dereference in SOAP apache:Map decoder with missing <value> (CVE-2026-7262) * php: signed integer overflow in metaphone() (CVE-2026-7568) * php: denial of service via DOMNode::C14N() (CVE-2026-7263) * php: global buffer over-read in mb_convert_encoding() with attacker-supplied encoding (CVE-2026-6104) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…