SUSE · security update for python3.11
Affects SUSESource GCVE Database
Not known to be exploited : upgrade SUSE to 3.11.7 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.7
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade SUSE to 3.11.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSE Product Security Team SUSE | Affected
| Fixed in
|
AI-suggested
A security update is available and should be applied. Red Hat has released patches for Red Hat Enterprise Linux 9.4 Extended Update Support and related products. Users should follow the Red Hat advisory RHSA-2025:0280 and apply the provided updates to remediate this vulnerability. Refer to https://access.redhat.com/articles/11258 for detailed update instructions.
Description
A security vulnerability identified as CVE-2024-9287 affects Python 3.11 versions prior to 3.11.7. The issue involves virtual environment (venv) activation scripts that do not properly quote paths, which could lead to security concerns. Red Hat has issued an advisory and released updates for Red Hat Enterprise Linux 9.4 Extended Update Support and related products to address this vulnerability. The severity is rated as moderate. No known exploits in the wild have been reported.
References
- access.redhat.com/errata/RHSA-2025:0280 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2321440 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_0280.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2024:10979 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_10979.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_11111.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2024-December/000668.html (opens in a new tab)
- suse.com/security/cve/CVE-2024-9287/ (opens in a new tab)