Skip to main content
CVE-2024-6923VulnerabilityPublished Updated

SUSE · security update for python3.9

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-6923· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium · fixed in SUSE package updates : update the Red Hat redhat/python3.9 package when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6, 9.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/python3.9 package to 9.8, 9.6 or 9.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/python3.9pkg:rpm/redhat/python3.9Other threatsAffected
  • <9.4
  • >=9.5 <9.6
  • >=9.7 <9.8
  • >=9.9
Fixed in
  • 9.4
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Security updates addressing this vulnerability are available from Red Hat and Ubuntu. Users should apply the official patches provided by their Linux distribution vendors to remediate the issue. Refer to the Red Hat advisory (RHSA-2024:6163) and Ubuntu security notices for detailed update instructions. No additional mitigations are required beyond applying these patches.

Description

CVE-2024-6923 is a medium severity vulnerability affecting the email module in CPython, including Python 2.7 and other versions. The issue involves improper quoting of newlines in email headers during serialization, which can lead to header injection. Fixes for this vulnerability are available from Red Hat and Ubuntu for affected versions.

References

Community reviews

Loading reviews…