Skip to main content
CVE-2026-9499VulnerabilityPublished Updated

Red Hat Security Advisory: qt5-qtbase security update

Affects Red Hat qt5-qtbaseSource GCVE Database

0
Compare
Authoritative record:CVE-2026-9499· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in Red Hat package updates : update Red Hat qt5compat when convenient.

Data as of 6 Nov 2026, 04:32 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.11.1, 6.8.8, 6.0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Qt to 6.11.1 or 6.8.8; Qt to 6.0.0.

Affected software

ProductAffectedFixed in
QtQtAffected
  • >=6.9.0 <6.11.1
Fixed in
  • 6.11.1
QtQtAffected
  • >=6.0.0 <6.8.8
Fixed in
  • 6.8.8
QtQtAffected
  • >=4.0.0 <6.0.0
Fixed in
  • 6.0.0
GitHubqt/qt5compatpkg:github/qt/qt5compatOther threatsAffected
  • =6.0.0
  • =6.9.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates for affected qt5-qtbase packages in Red Hat Enterprise Linux 8.8 variants. Users should apply the provided updates as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate this vulnerability. Since a fix is available, applying the official patch is the recommended mitigation.

Description

A security vulnerability (CVE-2026-9499) in the Qt5-qtbase package allows a denial of service via an out-of-bounds read in text codec handling. This flaw affects the base tools for string, XML, and network handling in the Qt software toolkit. Red Hat has issued an important security update for affected Red Hat Enterprise Linux 8.8 variants to address this issue.

References

Community reviews

Loading reviews…