Skip to main content
CVE-2026-11573VulnerabilityPublished

Red Hat Security Advisory: qt5-qtbase security update

Affects Red Hat qt5-qtbaseSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-11573· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade Red Hat qt to 6.8.2 soon.

Data as of 6 Nov 2026, 07:20 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade qt to 6.8.2.

Affected software

ProductAffectedFixed in
qtqtAffected
  • >=2.2.0 <6.8.2
Fixed in
  • 6.8.2
Mavenorg.qtproject/qtpkg:maven/org.qtproject/qtOther threatsAffected
  • =6.7.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for Red Hat Enterprise Linux 9.2 and related variants that address these vulnerabilities. Users should apply the security updates as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issues. No additional mitigation steps are indicated beyond applying the official patches.

Description

Two denial of service vulnerabilities have been identified in the Qt software toolkit's qt5-qtbase and qt6-qtbase packages. These issues involve uncontrolled recursion in XML serialization (CVE-2026-11573) and a denial of service vulnerability in XML parsing (CVE-2026-19248). Red Hat has issued an important security advisory with updates for affected Red Hat Enterprise Linux 9.2 variants to address these flaws.

References

Community reviews

Loading reviews…