Skip to main content
CVE-2026-13149VulnerabilityPublished Updated

Red Hat Security Advisory: Technical preview of the satellite/iop-vulnerability-frontend-rhel9 container image

Affects Red Hat brace-expansionSource GCVE Database

0
Compare
Authoritative record:CVE-2026-13149· High 7.7

Public exploit available · CVSS 7.7 High : upgrade Red Hat brace-expansion to 1.1.12 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P/S:N/AU:Y/R:U/V:D/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade brace-expansion to 1.1.12.

Affected software

ProductAffectedFixed in
npmbrace-expansionpkg:npm/brace-expansionOther threatsAffected
  • <1.1.12
Fixed in
  • 1.1.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Currently, there is no practical mitigation for this vulnerability. The brace-expansion package is typically a transitive dependency, making isolation difficult. Users should monitor Red Hat advisories and upgrade to a fixed version of brace-expansion when it becomes available. Red Hat Satellite documentation should be consulted for installation and configuration guidance.

Description

A denial of service (DoS) vulnerability exists in the brace-expansion npm package used by Red Hat Satellite's Lightspeed component. The expand() function can be triggered to consume excessive CPU and block the event loop by processing specially crafted strings with consecutive non-expanding brace groups, leading to exponential-time complexity. No practical mitigation is currently available other than upgrading to a fixed version when released.

References

Community reviews

Loading reviews…