Skip to main content
CVE-2024-56337VulnerabilityPublished Updated

Red Hat Security Advisory: tomcat security update

Affects Red Hat tomcatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-56337· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical.

Data as of 5 Nov 2026, 14:33 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • >=8.5.0 <=8.5.100
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated Tomcat packages (version 9.0.87-1.el9_4.4) for Red Hat Enterprise Linux 9.4 Extended Update Support and related variants that address these vulnerabilities. Users should apply these updates promptly following Red Hat's published guidance at https://access.redhat.com/articles/11258 to remediate the issues. No additional mitigation steps are indicated in the advisory.

Description

Red Hat has issued a security advisory for Apache Tomcat addressing two vulnerabilities. The first is CVE-2024-56337, an incomplete fix for a remote code execution (RCE) vulnerability due to a time-of-check to time-of-use (TOCTOU) issue in JSP compilation. The second is CVE-2025-31650, a denial of service (DoS) vulnerability caused by malformed HTTP/2 PRIORITY_UPDATE frames. These issues affect Red Hat Enterprise Linux 9.4 Extended Update Support and related variants. The advisory rates the update as important and provides updated Tomcat packages to remediate these vulnerabilities.

References

Community reviews

Loading reviews…