Skip to main content
CVE-2026-32762VulnerabilityPublished Updated

Ruby rack: From versions 3.0.0.beta1 to before 3.1.21 and 3.2.0 to before 3.2.6, Rack::Utils.forwarded_values parses

Affects ruby-rackSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.1.16-0.1ubuntu0.3 when convenient.

Data as of 3 Nov 2026, 23:21 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.1.16-0.1ubuntu0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu ruby-rack package to 3.1.16-0.1ubuntu0.3.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threatsAffected
  • 3.1.16-0.1 – 3.2.4-1ubuntu1.1
5 affected builds
Fixed in–
Ubuntu 25.10ruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=questingOther threatsAffected
  • <3.1.16-0.1ubuntu0.3
Fixed in
  • 3.1.16-0.1ubuntu0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading Ruby Rack to versions 3.1.21 or later, or 3.2.6 or later. For Ubuntu users, update to the fixed package version 3.1.16-0.1ubuntu0.3 or later as provided in the Ubuntu security notice USN-8182-1. After updating, restart any applications using Rack to apply the fix. No additional mitigation is required if the patch is applied.

Description

A vulnerability in Ruby Rack versions from 3.0.0.beta1 to before 3.1.21 and 3.2.0 to before 3.2.6 allows improper parsing of the RFC 7239 Forwarded header. Rack::Utils.forwarded_values splits on semicolons before handling quoted-string values, but quoted values may legally contain semicolons. This causes a single header value to be misinterpreted as multiple Forwarded directives, potentially enabling an attacker to smuggle host, proto, for, or by parameters through a single header. The issue has been patched in versions 3.1.21 and 3.2.6.

References

Community reviews

Loading reviews…