Skip to main content
CVE-2026-26961VulnerabilityPublished Updated

Ruby rack: Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser extracts the boundary parameter from

Affects ruby-rackSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 2.1.4-5ubuntu1.2+esm3 : update ruby-rack when convenient.

Data as of 3 Nov 2026, 23:21 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.1.4-5ubuntu1.2+esm3, 2.2.7-1ubuntu0.7, 3.1.16-0.1ubuntu0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu ruby-rack to 2.1.4-5ubuntu1.2+esm3 (package) or 2.2.7-1ubuntu0.7 (package) or 3.1.16-0.1ubuntu0.3 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threatsAffected
  • 3.1.16-0.1 – 3.2.4-1ubuntu1.1
5 affected builds
Fixed in–
Ubuntu 25.10ruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=questingOther threatsAffected
  • <3.1.16-0.1ubuntu0.3
Fixed in
  • 3.1.16-0.1ubuntu0.3
Ubuntu 24.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=nobleOther threatsAffected
  • <2.2.7-1ubuntu0.7
Fixed in
  • 2.2.7-1ubuntu0.7
Ubuntu Pro 22.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 2.1.4-5ubuntu1+esm2 – 2.1.4-5ubuntu1+esm5
  • <2.1.4-5ubuntu1.2+esm3
4 affected builds
Fixed in
  • 2.1.4-5ubuntu1.2+esm3
Ubuntu Pro 18.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 1.6.4-4 – 1.6.4-4ubuntu0.2+esm10
12 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/xenialOther threatsAffected
  • 1.5.2-4 – 1.6.4-3ubuntu0.2+esm10
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Ruby Rack versions 2.2.23, 3.1.21, and 3.2.6. Users should update to these or later versions to remediate the vulnerability. For Ubuntu users, security updates are provided in package versions 2.1.4-5ubuntu1.2+esm3, 2.2.7-1ubuntu0.7, and 3.1.16-0.1ubuntu0.3. After updating, restart any applications using Rack to apply the fixes.

Description

A vulnerability in Ruby Rack prior to versions 2.2.23, 3.1.21, and 3.2.6 allows improper parsing of multipart/form-data boundaries. Rack::Multipart::Parser uses a greedy regular expression that selects the last boundary parameter when multiple are present, while upstream proxies or intermediaries may use the first. This mismatch can enable an attacker to bypass upstream inspection and cause Rack to parse a different multipart body than validated. The issue has been fixed in the stated versions.

References

Community reviews

Loading reviews…