Skip to main content
CVE-2026-34785VulnerabilityPublished Updated

Ruby rack: Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Static determines whether a request should be served as

Affects ruby-rackSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 1.5.2-3+deb8u3ubuntu1~esm11 : patch ruby-rack soon.

Data as of 3 Nov 2026, 23:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.5.2-3+deb8u3ubuntu1~esm11, 1.6.4-3ubuntu0.2+esm10, 1.6.4-4ubuntu0.2+esm10 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threatsAffected
  • 3.1.16-0.1 – 3.2.4-1ubuntu1.1
5 affected builds
Fixed in–
Ubuntu 25.10ruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=questingOther threatsAffected
  • <3.1.16-0.1ubuntu0.3
Fixed in
  • 3.1.16-0.1ubuntu0.3
Ubuntu 24.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=nobleOther threatsAffected
  • <2.2.7-1ubuntu0.7
Fixed in
  • 2.2.7-1ubuntu0.7
Ubuntu Pro 22.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 2.1.4-5ubuntu1+esm2 – 2.1.4-5ubuntu1+esm5
  • <2.1.4-5ubuntu1.2+esm3
4 affected builds
Fixed in
  • 2.1.4-5ubuntu1.2+esm3
Ubuntu Pro 18.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/bionicOther threatsAffected
  • <1.6.4-4ubuntu0.2+esm10
Fixed in
  • 1.6.4-4ubuntu0.2+esm10
Ubuntu Pro 16.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/xenialOther threatsAffected
  • <1.6.4-3ubuntu0.2+esm10
Fixed in
  • 1.6.4-3ubuntu0.2+esm10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in Ruby Rack versions 2.2.23, 3.1.21, and 3.2.6. Users should update to these or later versions to remediate the vulnerability. For Ubuntu users, updated package versions are provided in the Ubuntu Security Notice USN-8182-1. After updating, restart any applications using Rack to apply the fix.

Description

A vulnerability in the Ruby Rack web server interface prior to versions 2.2.23, 3.1.21, and 3.2.6 allows improper handling of static file requests. Rack::Static uses a simple string prefix check to determine if a request should be served as a static file, which can unintentionally expose files whose names share the configured prefix, leading to potential information disclosure. This issue has been addressed in the specified patched versions.

References

Community reviews

Loading reviews…